服务热线
400-163-2080
技术支持(刘一二)
18637485800
刘一二微信
PHP BE 双驱框架

PHPBE双驱框架 是深圳店熵科技自主开发的一款高并发/高可用开源框架,支持标准 PHP 和 Swoole 两套驱动,同时它也是一个低代码开发框架及高可用解决方案

项目地址: https://www.phpbe.com

功能优势
普通PHP和Swoole双驱动
BE框架底层内置两套驱动,支持普通PHP和Swoole两种方式部署,根据不同部署环境启用不同的驱动,兼顾便捷与性能。
C10K高并发,高可用
基于Swoole的常驻内存,连接池,对象池,异步协程等特性,轻松实现C10K(每秒1万并发)
开发友好,无门槛
开发人员无需关注Swoole特性,仅需按照传统PHP方式开发,入门级PHP程序员可轻松驾驭高可用系统
低代码,快速迭代
BE框架对常用功能进行了封装(如:存储、计划任务、CURD、表单、报表等),大量使用注解自动实现(如:菜单、权限、路由、配置项等),实际开发中仅需要编写少量调用代码
持续升级,快速响应
BE框架正处于高速成长期,项目将长期快速迭代,持续升级改进,并对出现的问题快速响应,同时我们在使用中收集到的优秀创意将沉淀在框架设计中。
开源,无需费用
BE框架遵循完全没有限制的MIT开源协议,您可以放心使用,修改,并部署到商业化项目中。
店熵SAAS平台
店熵SAAS平台

ShopFai 店熵 SAAS 独立站平台由深圳店熵科技自主设计,开发, 包含广告投放、私域营销、数据驱动、全链集成等丰富功能,覆盖网站搭建、品牌营销、运营指导到支付成单等独立站出海全流程。

项目地址: https://www.shopfai.com

我们开发的开源软件
我们持续开发一些软件,少部分需要商业授权,大部分使用了最为宽松的MIT开源协议,您可以免费安装、使用、用于商业用途、或二次开发、销售。均无需支付费用,使用中遇到的问题可以反馈给我们协助解决。
ETL(Etl)
ChatGPT 自动化批量流程处理工具,轻量级 ETL 数据抽取,加工(支持ChatGPT),清洗,迁移、输出工具,
最新版本:v2.1.11 (发布于:2024年4月21日)
需商业授权
7960
4872
OpenAI 人工智能 ChatGPT(Openai)
基于 OpenAI 实验室的人工智能产品 ChatGPT 封装的应用,作为基础应用,安装后,BE 框架整站和全系APP 的编辑器 将获得 调用 ChatGPT 的能力。如CMS,商城,文档)无需任何配置,直接可以使用 ChatGPT 生成内容。也可在此应用基础上做二次开发,如用于自动化生成内容,自动化AI创作等场景,
最新版本:v1.1.6 (发布于:2023年6月23日)
composer require be/app-openai
6132
5202
AI 作家(AiWriter)
借助人工智能(如OpenAI ChatGPT)自动化海量生产内容,创作,改编等。
最新版本:v1.1.9 (发布于:2023年3月22日)
composer require be/app-aiwriter
5542
5002
店熵商城(Shop)
有别于常规的商城系统,这是一款 基于 ES 和 REDIS 实现的 可独立部署的。高负载、高并发、高可用版本 的 跨境电商独立站商城系统
最新版本:v1.3.10 (发布于:2023年12月30日)
需商业授权
6790
5846
猴子采集器(Monkey)
借助浏览器油猴插件,在目标页面加载完成后,向页面注入jQuery和JS脚本,通过jQuery + JS脚本采集所需内容。并跨域远程提交到采集系统。只要能通过浏览器访问,就100%能采集,特别擅长采集特殊页面的动态内容,如需要登录后才能看到的内容,滚动页面加载的内容,鼠标点击触发的内容等等等等
最新版本:v1.1.0 (发布于:2023年5月26日)
composer require be/app-monkey
12626
6056
内容管理系统(Cms)
以 Redis 缓存和 ES 搜索引擎支撑高负载应用场景; 可以支持亿级以上数据量的高并发访问;
最新版本:v2.7.7 (发布于:2024年3月17日)
composer require be/app-cms
7754
7294
公司(Company)
公司网站,企业站
最新版本:v1.0.6 (发布于:2023年2月6日)
composer require be/app-company
6502
5646
文档管理系统(Doc)
支持 Tinymce 和 Markdown 两种编辑器实时切换,数据全量同步到 Redis 和 Es 中。前端访问隔断数据库负载。BE官网网站的开发文档用的就是这个应用。
最新版本:v1.1.0 (发布于:2023年3月8日)
composer require be/app-doc
2998
51
导航